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The objective of the work is to evaluate the accuracy of two methods which are implemented 

in MATLAB (by Xinxin Yu) against a commercial software in case of Manchester 

Benchmark parameters (Iwnick, 1998). Two methods and the software above are all 

simulation tools for railway dynamics. The methods are the lookup table method (Escalona 

and Aceituno, 2019) and knife-edge-equivalent contact constraint (KEC) method (Escalona 

et al., 2019). The method of evaluation is comparing the simulation results of above two 

methods with the results from commercial software, Universal Mechanism (UM). 

 

Theoretical foundations for UM including information about wheel rail pair for this thesis, 

hunting, suspension systems, as well as cubic spline interpolation for profiles and irregularity 

are introduced. Integrators and contact models of UM, GENSYS and VI-Rail are 

investigated. Then a step-by-step example of building bogie with a primary suspension 

system in UM is shown. 

 

Comparison results between above mentioned methods and UM are shown in Chapter 4. The 

first simulation is single wheelset forward motion on a tangent track with different speeds. 

Hunting frequency calculated by using Klingel’s formula is the same as the frequency 

measured in simulation. During second set of simulation, the single wheelset travelled on a 

large radius curve and a small radius curve accordingly. The calculation result of the 

symmetry axis is the same as it measured from the result figure. Then the whole vehicle 

according to Manchester Benchmark standard (Iwnick, 1998) is applied. The whole vehicle 

is simulated on the small curve track. First travelled without irregularity, then with 

irregularities. The output results are the lateral displacements, and the yaw angles of each 

wheelset. Results from the lookup table method, the KEC method and UM agree well with 

each other. It can be concluded that lookup table method and the knife-edge-equivalent 

contact constraint method in case of Manchester Benchmark are verified against UM 

because they can get very close results with commercial software.  
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1 INTRODUCTION 

 

 

Urbanization is making the scale of cities expending, the negative influence of environment 

such as air pollution, the reduction of open space, farmland, the diversity of species 

(Johnson, 2001). The need for transportation is growing among cities. Growth of motor 

vehicle ownership adds more stress to traffic. Meanwhile, building more and wider roads 

cannot solve the problem because road construction cannot follow the speed of vehicle 

growth. Local recreation areas which are good for the both mental and physical health of 

city residents are reduced (von Hertzen, Hanski, & Haahtela, 2011). Constructing 

underground and light rail is another solution. However, as underground and light rail need 

high investment and have a high volume of transportation, long construction cycle and 

complex technology. The underground and light rail are more suitable for big cities with 

good economy shape. Building trams is a good solution due to its less investment, low 

operating costs, safe and reliable rail transit mode. Trams can, improve road capacity and 

less pollution of a public transport system. 

 

Railroad vehicles such as trams, underground and trains are extensively used methods for 

carrying people and goods. Due to rail transportation technology, modern trains can function 

in high speed with optimized costs and time. Railway transport also has lower carbon dioxide 

emission than airplane (www.dw.com, 2018). Airplane transports are restricted since 

COVID-19 outbreaks in 2020. Limited flights and high costs make airplane transport not the 

best option for transporting industries and medical supplies. Container trains transport has 

become the best option for Finnish companies and the volume of railway freight had already 

hit a high record before April (english.anhuinews.com). Besides cheaper than airfreight, the 

advantage of railway transport during the epidemic is that, transporting containers does not 

need additional personal. Unlike the shipping transport, ship crews need to obey quarantine 

regulations in destination cities, which increase the round-trip time. What is more, if one of 

the crew is infected in limited space such as ships, others are in high risk during the journey. 

 

At the same time, safety, comfort level and low noise are still main issues. Derailment can 

be eliminated by identifying the causes of it. The comfort level and reduced noise can be 

achieved by limiting vibrations. Modern trains that have complex structure can be easier 
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simulated by modern computational dynamics. Dynamic simulation of railroad can help 

improve existing railroad vehicles. Figure 1 shows a tram in front of Helsinki Central 

Railway Station. 

 

 

Figure 1. Tram in front of Helsinki Central Railway Station. 

As the computer aided analysis is becoming an important method in design processes, 

simulations of electrical systems, hydraulic systems, robots, mechanisms, machines, and 

vehicles have been used widely. Unlimited numbers of measurable parameters can be 

measured by non-invasive methods. It is less time-consuming and cheap compare with 

experimental studies.  

 

Computational dynamics provide tools for multi body system dynamic simulation. Usually 

there are various tools available for the simulation of a system. With the help of advanced 

computers with high calculating speed, analysing complex systems where there are lots of 

bodies and joints became possible. Conventional approached based on Lagrangian 

mechanics and Newtonian mechanics are converted into suitable forms for computers. 

(Shabana, 2009) 

 

1.1 Objectives 

This work comes from Smart tram project (www.vttresearch.com) with reference 

6292/31/2018 and supervised by Xinxin Yu. The objective of the work is to evaluate the 

accuracy of the lookup table method (Escalona and Aceituno, 2019) and knife-edge-

equivalent contact constraint (KEC) method (Escalona et al., 2019) which are implemented 
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in MATLAB (by Xinxin Yu) in case of Manchester Benchmark parameters (Iwnick, 1998). 

Two methods and the software mentioned above are all simulation tools for railway 

dynamics. The method of evaluation is comparing the simulation results of above 2 methods 

with the results from commercial software, Universal Mechanism (UM).  

 

The evaluation process includes three sets of experiments: single wheelset forward motion 

on a tangent track with different speed (15 m/s, 25 m/s, and 45 m/s); single wheelset 

travelling on a large radius (R= 4545 m) curve and a small radius curve (R= 235 m) 

accordingly; the whole Manchester Benchmark vehicle travelling on a small curve track (R= 

500 m) without and with irregularities successively. The hunting frequencies, symmetry 

axes, lateral displacements, yaw angles are compared during the verification.  

 

1.2 Structure of the thesis 

Background and advantage of the railway vehicle is introduced in Chapter 1. The need for 

transportation is growing with urbanization. Railway transport is quick, cheap, and time 

saving. Especially during COVID-19 outbreak, the railway transport of goods between 

countries is more popular. Then the objective of this work is listed. 

 

Theoretical foundations for UM including the rail wheel pair, hunting, suspension systems, 

as well as cubic spline interpolation for profiles and irregularity are introduced in Chapter 2. 

 

The function and theory (integrator and contact model) of UM, GENSYS and VI-Rail are 

introduced in Chapter 3. Then an example of building bogie with the primary suspension 

system in UM is followed. 

 

Chapter 4 includes results comparison and analysis between UM and Lookup table. The 

important contact parameters and the irregularities of the rails are emphasized. Results from 

lookup table method, KEC method and UM agree well with each other. 

 

Chapter 5 summaries the thesis and concludes that the lookup table and the knife-edge-

equivalent contact constraint method are verified because they can get very close results with 

the commercial railway dynamic software Universal Mechanism.  
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2 THEORETICAL FOUNDATION 

 

 

The simulation software used in this thesis is Universal Mechanism. The profiles of wheels 

and rails, the geometries of track centerlines, the bogies and vehicle, the suspension systems, 

the irregularities are built in UM. Theoretical foundations of above steps in UM are 

introduced in this chapter. 

 

2.1 Wheel rail pair 

For railway vehicles in general, the wheelset consists of two wheels and an axle. The wheels 

are cone shape in general. There are two different parts in detail: flange and tread. The shape 

of the wheel rail pair can be found in Figure 2. Above design gives wheelsets the ability of 

self-steering during the motion on rails. The motion of steering consists of yaw and roll 

rotation. During the rotations, the lateral positions of the wheelset vary. The steering process 

is called hunting. Ideal condition shown in Figure 3 (a) is that when the wheelset is traveling 

on rail, only tread part contact with rail. There is only normal contact force between wheel 

treads and rails. If the hunting oscillation is violent or the wheelset is passing small-radius 

curve, flange contact will occur as shown in Figure 3 (b). Besides normal contact force 

between wheel tread and rail, there is another contact force between the wheel flange and 

rail. There is a risk of derailment for the vehicle if the flange contact is violent. The default 

contact model in Universal Mechanism is FASTSIM. 

 

 

Figure 2. Schematic diagrams of wheel rail pair. 
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Figure 3. Tread contact (a) and flange contact (b) of wheel rail pair. 

 

Evaluating the motion of the whole vehicle or vehicle parts are important in railway vehicle 

dynamics. There are 6 degrees of freedom for wheelset and rail relative motions (Pombo, et 

al., 2004). The type of the motions, as well as their description, symbol, and representation 

symbol in UM are listed in Table 1. Figure 4 shows the coordinates for one wheelset in UM. 

 

Table 1. Explanations of relative motions 

Motion type Description Symbol Symbol in UM 

Longitudinal Forward translation 𝑥 X1.1 

Lateral Translation in lateral direction 𝑦 X1.2 

Vertical Translation in vertical direction 𝑧 X1.3 

Roll Rotation about Y axis 𝜑 X1.6 

Pitch Rotation about X axis 𝜒 X1.5 

Yaw Rotation about Z axis 𝜓 X1.4 
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Figure 4. Wheelset and coordinates in UM Input. 

 

2.2 Suspension system 

The suspension systems in railway vehicles absorb vibrations which are harmful to vehicle 

elements during the journey. For example, hunting oscillation can lead the vibration of 

wheelset axle. If the vehicle travels under critical speed, the amplitude will gradually 

approach 0 because of the suspension system. In general, the suspension system consists of 

primary and secondary suspension. (Anon) (Continental-railway.com, 2020) 

 

Primary suspension connects the wheelsets and bogie. During simulation for this thesis, as 

Figure 5 shows, there are 3 sets of springs (in longitudinal, lateral, and vertical direction) 

and 1 set of dampers (vertical direction) attached to wheelsets. With primary suspension, the 

bogie with wheelset can stably travel on track with irregularities. 

 

Secondary suspension connects car body with bogie. For each bogie, there are 2 set of 

dampers (in lateral and vertical direction), 1 set of springs (in vertical direction) and a 

traction rod (in longitudinal direction). The function of secondary suspension is reducing the 

effect of track irregularity on the vehicle. Figure 6 shows the dimensions of the suspension 

system. Figure 7 shows the overall view of the suspension system with the whole vehicle. 

 



12 

 

 

Figure 5. Primary suspension between bogie and wheelset. 

 

 

Figure 6. Dimensions of Manchester Benchmark vehicle suspension system (Iwnick, 1998). 
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Figure 7. Overall view of suspension system with the whole vehicle. 

 

  

2.3 Hunting and critical speed 

The hunting oscillation of a railway vehicle is a phenomenon that wheelset have an ‘S’ shape 

movement from top view when the vehicle moving forward. When wheelset is not centered 

on the track, there will be a difference of effective diameter (𝑅0) between two wheels 

because of cone tread. The condition above will lead to a lateral oscillation together with 

yaw rotation named hunting oscillation, where the system is hunting for equilibrium. 

Hunting can be resulted by high conicity. Critical hunting has negative influence on 

characteristics: decrease the comfort level, make the train more easily to derailment and 

harmful to the track. (Shevtsov, et al., 2005) (Sun, et al., 2019) 

 

Common understanding of critical speed expects hunting oscillation. The oscillation 

increases with increasing speed. For soft subgrade railways, if trains travel near or faster 

than the Rayleigh wave velocity of subgrade soil, the speed is critical speed. (Gao, et al., 

2017) In this thesis, critical speed is measured as speed when suspension systems can no 

longer reduce hunting phenomenon. Hunting frequency has a huge effect on wheelset 

hunting. The forward speed has positive correlation with hunting frequency. (Sun, et al., 

2019) 
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2.4 Interpolation methods for cubic spline 

The wheel and rail profiles, centerline of general tracks, and track irregularities are all 

defined by a set of points in simulation for this thesis. Cubic splines connect every two 

neighboring points. So, the first and second derivatives of every point in the spline segment 

can be calculated. The cubic spline is defined as (Barsky, 2013): 

 

𝑔(𝑢) = 𝑎3𝑢
3 + 𝑎2𝑢

2 + 𝑎1𝑢 + 𝑎0 (1) 

 

where 𝑔(𝑢)  is the point on the spline, 𝑢  is variable, coefficients 𝑎𝑖  needed to be 

calculated. Presume that there are 2 points defined by user: (0,1) and (1,2). The points are 

substituted into equation (1). The equation and its first derivative are: 

 

{
 

 
𝑔(1) = 𝑎3 + 𝑎2 + 𝑎1 + 𝑎0
𝑔′(1) = 3𝑎3 + 2𝑎2 + 𝑎1

𝑔(2) = 8𝑎3 + 4𝑎2 + 2𝑎1 + 𝑎0
𝑔′(2) = 12𝑎3 + 4𝑎2 + 𝑎1

(2) 

 

 

as there are 4 unknowns and 4 equations. Coefficients 𝑎𝑖 are solvable. The spline can be 

defined.  
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3 SOFTWARE TOOLS FOR RAILROAD DYNAMIC 

 

 

Some well know commercial simulation software of railway dynamic are VI-Rail, GENSYS, 

SIMPACK, VAMPIRE (Pombo, et al., 2004). Integrators and contact models of GENSYS, 

VI-Rail and UM are counted by email interview and documentation reading. 

 

Universal Mechanism (UM) is a multi-body system program package, which is for both 

planar and spatial mechanical systems. The application fields of UM are, for example, 

automotive, rail vehicles, flexible bodies, trains, tracked vehicles. 

(www.universalmechanism.com) 

 

3.1 Integrators and contact model among commercial software 

Originally, VI-Rail was implanted by MDI company as ADAMS/Rail. The name of the 

software became to VI-Rail after MSC company acquired MDI company. VI-GRADE was 

founded by former employees of MDI company so there is no change of developers. VI-Rail 

and ADAMS/Rail are technically the same. (Volker, 2020) 

 

As of above reason, all integrators in Adams solvers are also available in VI-Rail. For 

example, GSTIFF, WSTIFF, HASTIFF, HHT and NEWMARK with different formulations 

and settings. The default integrator of VI-Rail is GSTIFF. GSTIFF is also recommended by 

the official documentation of VI-Rail. 

 

VI-Rail uses contact implementation by W. Kik. Modified FASTSIM or the Polach method 

can be selected for the calculation of creep forces. Serval wheel rail elements available in 

VI-Rail are listed below (Volker 2020): 

• Quasi-linear element type allows user to analyze the effects of parameters separately 

from defined rail and wheel profiles. The parameters include conicity, the contact 

angle, and roll angle. The vehicle stability can be learnt by using Quasi-linear 

element type. 

• Element type with pre-calculated kinematic table uses an ellipse to approximate 

contact patch. This type is based in kinematics on defined rail and wheel profiles. A 
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constant value is used for the stiffness. There is one contact patch per interconnection 

only. 

• Wheel rail interconnection element uses Boussinesk formulation to model non-

elliptical contact patches and contact stiffness. The number of contact patches in one 

interconnection is not restricted. This element is the most general element among 

these three. 

 

GENSYS does not recommend using high order integration methods to do railway vehicles 

dynamic simulations. It is because the flange contact between rail and wheel is highly non-

linear. A method with few steps does not try to linearize the problem. It is more suitable for 

capturing the short duration of force peak. Different integration methods with their codes in 

GENSYS are listed in Table 2 below (Ingemar, 2020) : 

 

Table 2. Integration methods in GENSYS (www.gensys.se, modified). 

Code name Explanation of the code 

e1  Euler forward. 

mp2  The midpoint method. 

runge_kutta  The four step Runge-Kutta method. 

heun  The two step Runge-Kutta method. 

heun_u  The two step Runge-Kutta method with step size control. 

heun_c  The two step Runge-Kutta method with step size control, may have 

backsteps. 

heun_d  The faster execution of heun_c. 

heun2impl  The implicit Heun's method. 

dopri5  The explicit Runge-Kutta. 

radau5  The implicit Runge-Kutta method of order 5. 

odassl  The implicit DAE-solver. 

 

There are many contact models available in GENSYS package. The full version can be found 

in Appendix 1. Three of the contact models that based on FASTSIM code and their code 

name are listed in Table 3 below: 
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Table 3. Contact models related with FASTSIM in GENSYS (www.gensys.se, modified). 

Code name Explanation of the code 

creep_fasim_1  Rolling contact. Using linear spring and Kalker's fasim routine for 

normal contact and tangential contact accordingly. 

creep_fasim_2  Similar to fasim_1, with different creepages formulas. 

creep_fasim_4  Similar to fasim_1, but the wheel and rail profiles are used directly. 

 

In addition, using "func wr_coupl_XXX" command in GENSYS can create both wheel/rail 

coupling and massless rail with stiffnesses and dampers under the rail. The advantage of this 

command is that the simulation runs faster with massless rails. 

 

3.2 Integrators and contact model in Universal Mechanism 

Various integration methods are available in UM. DAE (ordinary differential-algebraic) 

equations are for objects with closed kinematical loops. Integration methods below are for 

both DAR and ODE (ordinary differential equations) (UM Simulation Program User’s 

manual 2018): 

• BDF: Backward Differentiation Formula. This is an explicit prediction-evaluation-

correction solver. Order is up to fifth. The step size and order may vary. BDF is for 

non-stiff equations only. 

• ABM: Adams-Bashfort-Moulton method. This is explicit prediction-evaluation-

correction-evaluation solver. Order is up to eleventh. Step size and order may vary. 

ABM is for non-stiff equations only. 

• PARK: PARK is a second order implicit solver. The step size may vary. PARK is 

for stiff ODE and DAE. 

• GEAR 2: GEAR 2 is a second order implicit method. The step size may vary.  

• RK4: RK4 is the 4th order Runge-Kutta method. The step size is constant. RK4 is 

not suitable for DAE. 

• Park parallel: Park parallel is finite-difference methods based on PARK. Equations 

of motion are generated by special methods. The Park parallel method utilizes multi-

core processors to parallel computations. The Park parallel is more efficient than 

PARK.  
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3.3 Wheelset parameter 

Figure 8 shows the geometry of the wheelset. Distance between wheelset center and wheel 

center, which is called ‘Semibase’ in UM, is 𝐿 = 0.7515 m. Running circle radius 𝑅0 =

0.457 m, Which is the distance between ideal contact point on tread and the center line of 

wheelset. Conicity alpha 𝛼 = 0.025 rad. Other parameters are listed in Table 4. 

 

 

Figure 8. Wheelset geometry (Simulation of Rail Vehicle Dynamics User’s manual, 

modified). 

 

Table 4. Wheelset parameter. 

Parameters Model 

Wheelset mass (kg) 1568 

Wheelset inertia 𝐼𝑥𝑥 𝐼𝑦𝑦 𝐼𝑧𝑧 

𝐼𝑥
𝑤ℎ 𝐼𝑦

𝑤ℎ 𝐼𝑧
𝑤ℎ (kgm2) 656, 168, 656 

Running circle radius (m) 0.457 

Semi base (m) 0.7515 

Hertzian stiffness (kN/m1.5) 1 × 107 

Damping parameter (kN/m/s) 1 × 105 

Inclination angle (rad) 0.025 
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3.4 Creating a wheelset in UM input 

Figure 4 in Chapter 2 showed the wheelset and coordinates in UM input. Parameters of 

wheelset and wheelset inertia can be modified under ‘general’ and ‘identifiers’ tab. The 

model needs to be saved in order to start simulation in UM Simulation software. 

Path below shows the instruction of creating a wheelset: 

• UM Input main menu > file > new object > subsystems > add new element > type: 

wheelset 

 

Figure 9 shows setting the initial condition of wheelset. As mentioned before in Chapter 2, 

the 1.2 means the lateral position of wheelset 1. There are also +2 mm in lateral directions 

for every wheelset, bogie, and the car in later simulation. The path below shows the 

instruction of setting initial condition: 

• UM simulation main menu > analysis > simulation > initial conditions > coordinates 

 

 

Figure 9. Setting initial conditions. 

 

3.5 Wheel and rail profile 

After wheelset is built and saved in UM input, simulation shall be started by ‘Run UM 

Simulation program’ function. Next step is setting wheel and rail profiles. Through the 

simulation inspector, ready wheel and rail profiles can be loaded. UM also allows editing 
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rail and wheel profiles by users. Path below shows the instruction of creating wheel and rail 

profile: 

• UM Input main menu > tools > railway wheel and rail profile editor 

 

Wheel and rail profiles are constructed using a set of nodal points. Spline interpolation is 

used to parameterize the profile. Point list consisted by two columns is pasted into the 

railway wheel and rail profile editor. The order of the list is ascending order with X axis. 

The unit is in millimeter. Figure 10 and Figure 11 shows the profiles of the right wheel and 

the right rail accordingly. The right wheel and right rail are the mirror of the left wheel and 

the left rail accordingly. Right wheel and rail profiles are enough to assign both rails and 

wheels. 

 

 

Figure 10. Right wheel profile built by points. 
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Figure 11. Right rail profile built by points. 

 

Figure 12 shows the analysis of the right wheel and right rail profile. The type of contact is 

2-point contact. The figure shows tread contact. In case of hunting motion, flange contact 

will appear. 

 

 

Figure 12. Analysis of right wheel and rail profile. 

 

3.6 Track macro geometry 

Track macro geometry can be defined both by various sections (including tangent sections, 

curve sections, switch sections) and pointwise curves. In this thesis, pointwise curves are 

used to describe track macro geometry. Figure 13 shows the horizontal track profile in UM 
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track macrogeometry editor. The vertical macro geometry is tangential. The path below 

shows the instruction of adding pointwise curve: 

• UM Simulation main menu > tools > macrogeometry editor > railway or monorail 

track > add section > add pointwise curve 

 

 

Figure 13. Horizontal track profile in the track macro geometry editor. 

 

3.7 Simulation of one wheelset forward motion 

Simulations of one wheelset motion are done under different speed and track type. On 

tangent tack, speeds of 15 m/s, 25 m/s, and 45 m/s are tested. The initial speed is constant 

applied on wheelset, if there is a bogie or a car in the simulation, it should be applied on the 

element which with the highest mass. Speed of 20 m/s is used in a steady curving large radius 

curve (R=4545 m) and small radius curve (R=235 m). Paths below show the instructions of 

initial speed, speed type, applying macro geometry, applying irregularities, applying wheel 

and rail profiles accordingly: 

• UM Simulation main menu > Analysis > Simulation > Identifiers > List of identifiers 

> Whole list > v0 

• UM Simulation main menu > Analysis > Simulation > Rail/Wheel > Speed > Mode 

of longitudinal motion > Neutral 

• UM Simulation main menu > Analysis > Simulation > Rail/Wheel > Track > 

Macrogeometry > Track type > From file 

• UM Simulation main menu > Analysis > Simulation > Rail/Wheel > Track > 

Irregularities 



23 

 

• UM Simulation main menu > Analysis > Simulation > Rail/Wheel > Wheels > 

Profiles 

• UM Simulation main menu > Analysis > Simulation > Rail/Wheel > Rails > Profiles 

 

Figure 14 shows setting of vehicle initial speed under identifiers tab in the object simulation 

inspector. Figure 10 shows the initial speed is set as constant and applied on the single 

wheelset. The speed should be applied to the bogie or the vehicle car if the testing subject is 

bogie or the whole vehicle accordingly. As it showed in Figure 16, mode of creep force is 

set as FASTSIM, Young’s modulus is set as 2.1 × 1011, Poisson ratio is set as 0.3. 

 

 

Figure 14. Setting of initial speed. 

 

 

Figure 15. Setting of speed type. 
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Figure 16. Settings of contact force. 

 

3.8 Output numerical results 

Desired variables can be chosen in ‘wizard of variables’ under ‘tool menu’. The lateral 

displacement of wheelset is considered as important output in this simulation. Figure 17 

shows variables selected from the wizard of variables in plots. As shown in Figure 18, 

because lateral displacement is respect to the local coordinate of wheelset, it should be 

chosen under ‘Track Coordinate System’ in ‘Wizard of Variables’. The variable can be 

added into the container by double clicking. Variables for the yaw angles of wheelsets and 

positions alone tracks are under ‘Rail/Wheel’ tab. Results can be plotted into ‘Graphical 

window’ under ‘tool’ menu. Paths below show the instructions of graphical window, the 

wizard of variables, setting of lateral displacement and yaw angle, position along track 

accordingly: 

• UM Simulation main menu > Tools > Graphical window  

• UM Simulation main menu > Wizard of variables > Track coordinate system > WSet 

> Type > Coordinate > Component > Y 

• UM Simulation main menu > Wizard of variables > Wheelsets > WSet1 > yaw 

• UM Simulation main menu > Wizard of variables > Wheelsets > WSet1 > Position 
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Figure 17. Plotting variable. 

 

 

Figure 18. Setting variable for lateral displacement. 

 

3.9 Example of creating one bogie with primary suspension 

As Figure 5 in Chapter 2 shows, two wheelsets are suspended with a bogie (replaced by a 

box) by springs and dampers. The box and four set of springs with dampers are set as images 

in UM input, which means shapes have no influence on dynamic.  

 

3.9.1 Creating wheelset 

To create a new object file and wheelset, instructions below shall be followed: 

1. UM Input main menu > File > New object 
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2. Object > Subsystems > Add new element > Type: Wheelset > Type of wheelset > 

Standard （Figure 19） 

3. Object > Subsystems > Name 

Name of the wheelset can be changed to WSet1.  

4. Object > Subsystems > Position > x1 

Enter the position value x1 for the wheelset. Then add identifier  x1 = 1.28 

according to Manchester Benchmarks for Rail Vehicle Simulation (Iwnick, 1998) 

(Figure 19) 

5. Object > Subsystems > WSet1 > general and identifier 

Enter 𝑅 = 0.457 m as radius of the wheelset, 𝐿 = 0.7515 m as semibase. Enter 

the mass 𝑚𝑤𝑠𝑒𝑡 = 1813 kg , moments of inertia 𝑖𝑥𝑤𝑠𝑒𝑡 = 1120 kgm2 ,  

𝑖𝑦𝑤𝑠𝑒𝑡 = 112 kgm2. (Figure 20) 

6. Object > Subsystems > WSet1 (right click) > copy element 

After copying the wheelset, rename it as WSet2. Change the position of WSet2 to -

x1. Same paths are used from above. 

 

   

Figure 19. Adding a wheelset into subsystem. 
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Figure 20. Mass and inertia parameter of wheelset. 

 

3.9.2 Creating spring and damper as image 

Spring and damper shape images are loaded to represent the spring and damper force of 

primary suspension for later use. Paths below are followed: 

1. Object > Images > Add graphic object > Description > Type: Spring 

Rename the spring as ‘SpringGO’ to represent the spring for later use. The GO image 

of spring is created and shown in Figure 21. 

2. Tool panel > Edit > Read from file> C:\Users\Public\Documents\UM Software 

Lab\Universal Mechanism\8\rw\Images\ > Damper 

 

 

Figure 21. Adding image of spring. 
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3.9.3 Creating bogie 

The bogie is created as an image, added to body so that it can react with primary suspensions. 

Paths below are followed: 

1. Object > Images > Add graphic object > Description > Type: Box 

The same instructions are followed in creating spring as an image section. Rename 

the box as bogie. The image of bogie and its parameter is shown in Figure 22. 

2. Object > Images > Add graphic object > Description > Parameter 

Parameters of the box are set and shown in Figure 22 referencing Manchester 

Benchmark. 

3. Object > Bodies > Add new element > Parameter > Image > Bogie 

The image of bogie is added into body and shown in Figure 23 (a). Then mass and 

inertia parameter are set according Manchester Benchmark. 

4. Object > Bodies > Parameter > Go to element > Create joint > 6. d. o. f.  

6 degrees of freedom is set as joint type and shown in Figure 23 (b). The degrees of 

freedom that the joint allocates including 3 translational movements in three-

dimensional Cartesian coordinate and 3 rotational movements. 

 

 

Figure 22. Parameter of bogie as image. 
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(a) (b) 

 

 

 

Figure 23. Creating bogie as body, modifying its parameter (a), and creating joint for bogie 

(b). 

 

3.9.4 Bipolar force element 

A bipolar force element consists of a force between two fixed points in a line. The force may 

depend on distance, time, or time derivative of distance. Bipolar force is chosen to describe 

the spring and damper forces in this thesis. Below are paths to create spring elements in 

vertical direction: 

1. Object > Bipolar forces > Add new element > Type > Linear 

A linear type bipolar force is created and shown in Figure 24. The spring force 

element is represented by the GO image of spring. Rename the force as springZ1L. 

2. Object > Bipolar forces > springZ1L > Attachment points 

The force of springZ1L acts between the front left wheelset and Bogie. Attachment 

points are set and shown in Figure 25. The parameter 𝑐𝑜𝑜𝑟𝑑𝑖𝑛𝑎𝑡𝑒 𝑋0 means the 

default length of the spring. It is calculated as: 

 

𝑋0 = ℎ2 − ℎ1 + 𝑓𝑠𝑡1 (3) 
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where ℎ1 is the height of primary spring, ℎ2 is the height of the bogie frame end. 

The 𝑓𝑠𝑡1 equals the compressed length of the spring so that the springs can support 

their loads and keep other components stay at right places in the equilibrium state, in 

this case the load is the mass of bogie. The 𝑓𝑠𝑡1 is calculated as:  

 

𝑓𝑠𝑡1 =
𝑚𝑏𝑜𝑑𝑦 +𝑚𝑏𝑜𝑔𝑖𝑒

9.81 ∙ 4 ∙ 𝑐1𝑧
(4) 

 

where 𝑚𝑏𝑜𝑑𝑦 is the mass of vehicle body. The 𝑚𝑏𝑜𝑔𝑖𝑒 is total mass of all bogies. 

The number 4 is the quantity of springs. The 𝑐1𝑧 is vertical stiffness of spring. After 

that, copy the force springZ1L 3 times, edit both acting body and attachment points 

according to Manchester Benchmark vehicle. All 4 springs in vertical direction are 

built. 

 

Figure 24. Creating bipolar force element. 
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Figure 25. Attachment points and parameter of spring1Z. 

 

3.9.5 Adding damper to vertical direction 

A Viscous-elastic type of bipolar force is created and shown in Figure 26. Viscous-elastic 

element includes a linear spring, a parallel connection of spring and damper. In this case the 

parallel spring constant 𝑐1 = 0, the linear spring only connects with a damper in series. The 

spring constant in series 𝑐1𝑆𝑒𝑟𝑖𝑒𝑠𝑍 = 1 × 106 N/m , coefficient of linear dissipation 

𝑑1𝑧 = 4000 Ns/m. 

 

3.9.6 An example of spring and damper force in the longitudinal direction 

The spring is created in the same way above. As it showed in Figure 27, the type is chosen 

as Expression so that both spring force and damper force can be included. The force 

expression that integrates spring and damper in longitudinal direction is expressed as: 

 

𝐹 = −𝑐1𝑥 ∙ (𝑥 − 𝑥1 + 𝑥2) − 𝑑1𝑥 ∙ 𝑣 (5) 
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where 𝑐1𝑥 is longitudinal stiffness, 𝑥 is real-time length of the spring, 𝑥1 is wheelset 

end semi-spacing, 𝑥2 is the bogie frame end semi-spacing, 𝑑1𝑥 is nominal damping in 

parallel of longitudinal stiffness, 𝑣 is vehicle speed. 

 

 

Figure 26. Damper in vertical direction on front wheelset. 

 

 

Figure 27. Spring and damper force expression in longitudinal direction. 
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3.9.7 Example of spring and damper force in lateral direction 

As Figure 28 shows, the force of spring and damper in lateral direction are created in the 

same way as springX1L. The expression of the force is: 

 

𝐹 = −𝑐1𝑦 ∙ (𝑥 − 𝑦1 + 𝑦2) − 𝑑1𝑦 ∙ 𝑣 (6) 

 

where 𝑐1𝑦 is lateral stiffness, 𝑥  is real-time length of the spring, 𝑦1 is wheelset end 

semi-spacing in the lateral direction, 𝑦2 is bogie frame end semi-spacing in the lateral 

direction, 𝑑1𝑦 is nominal damping in parallel of lateral stiffness, 𝑣 is vehicle speed. 

 

 
Figure 28. Settings of spring and damper in lateral direction between front wheelset and 

bogie.  
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4 NUMERICAL RESULTS AND ANALYSIS 

 

 

The simulation results of one wheelset and Manchester Benchmark vehicle are introduced 

in this chapter. Figure 29 shows the two-point contact of the wheel rail profiles, which is 

appeared in both simulations. The important parameters of wheelsets are listed in Table 5. 

The 𝑅0 is running circle radius. The 𝛼 is conicity. Figure 30 shows ideal distance between 

the origin points of wheel frame and rail frame ∆𝑦. ∆𝑦 can be expressed as (Simulation of 

Rail Vehicle Dynamics User’s manual): 

 

∆𝑦 =
𝐿𝑟 − 𝐿

2
(7) 

 

where 𝐿𝑟  is the distance between centers of rail heads, 𝐿  is the distance of wheelset 

running circles on left and right rail. 

 

 
Figure 29. Benchmark wheel rail profile with two-point contact. 

 

 

 
Figure 30. Benchmark wheel rail distance (Simulation of Rail Vehicle Dynamics User’s 

manual). 
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Table 5. Parameter of Benchmark wheel rail profile with two-point contact. 

Parameter  𝐿 (m) 𝑅0 (m) 𝐿𝑟 (m) 𝛼 (rad) 

Value 0.7515 0.457 0.7555 1/40 

 

Track irregularities are formed by spectral density functions (PSD) (Claus and Schiehlen, 

1998). Points are pasted to UM irregularity editor to generate the irregularities related to 

both left and right rails. The irregularities of left and right lateral, left and right vertical are 

shown accordingly in Figure 31. 

 

 

 

 

 

(a) 

(b) 
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Figure 31. Irregularities of (a) lateral left, (b) lateral right, (c) vertical left, and (d) vertical 

right.  

 

4.1 Klingel’s frequency analysis of unsuspended wheelset on tangent track 

Results of one wheelset forward motion on a tangent track are shown in Figure 32, Figure 

33 and Figure 34. Wheelset with the constant forward speeds of 15 m/s, 25 m/s, and 45 m/s 

accordingly. Numerical results from UM and the lookup table method (Escalona, et al., 

2019) are compared. 16.672 s is used for the 10 s simulation. Step size is 0.01. Results from 

UM agree well with MATLAB. 

 

X coordinates are time, Y coordinates are lateral displacements of wheelset respected to the 

projection on track. Results from UM are shown in continuous line. Results from lookup 

table method is shown in dotted line. 

 

(d) 

(c) 
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Motion of one wheelset is unstable laterally because the wheelset is unsuspended. The initial 

lateral position is 3 mm. As the speed of wheelset grows, the cycle time is getting shorter 

and the wheelset is getting more and more unstable. The frequencies of 3 simulations obey 

Klingel’s formula which is for the frequency of the small-scale kinematic oscillations of 

wheelset (Antali, et al., 2015): 

 

𝜔 = 𝑉√
𝛼

𝐿𝑤𝑅0
(8) 

 

where 𝛼 is conicity of wheels as shown in Figure 8, 𝐿𝑤 is the distance from wheel center 

to wheelset center, 𝑅0 is the running cycle radius of the wheels when wheelset is centered 

on the track. For example, as it showed in Figure 32, forward velocity V = 15 m/s, ω =

15 × √
0.025

0.75×0.457
= 4.05 and T =

2π

ω
= 1.55 s. Frequency calculated by Klingel’s formula 

is equal to the frequency of results from UM and Lookup table. 

 

  

Figure 32. Comparation of 𝑦𝑤ℎ between UM and Lookup table with forward velocity 15 

m/s. 

 

Time t (s) 
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Figure 33. Comparation of 𝑦𝑤ℎ between UM and Lookup table with forward velocity 25 

m/s. 

 

 

Figure 34. Comparation of 𝑦𝑤ℎ UM and Lookup table with forward velocity 45m/s. 

 

4.2 Stability analysis of unsuspended wheelset on a constant curvature track 

This section presents the stability analysis of an unsuspended wheelset on different constant 

curvature tracks as shown in Figure 35 and Figure 36. Figure 37 is the comparison of 

wheelset lateral displacement in a steady curving large radius curve (R= 4545 m) between 

UM and Lookup table. Forward velocity is 20 m/s. The hunting is unstable. Symmetry axis 

𝑦𝑠𝑡𝑑
𝑤ℎ of oscillation follows equation (Escalona, et al., 2012): 

 

𝑦𝑠𝑡𝑑
𝑤ℎ = −

𝐿𝑤𝑅0
𝛼𝑅

(9) 

Time t (s) 

Time t (s) 
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where 𝑅  is the radius of the curve. As shown in Figure 37, on large radius part, the 

oscillation is symmetry around -3 mm, which obeys 𝑦𝑠𝑡𝑑
𝑤ℎ = −

0.75×0.457

0.025×4545
= −0.003 𝑚.  

 

Figure 38 shows comparation of wheelset lateral displacement on the general track with the 

small radius curve. 𝑦𝑠𝑡𝑑
𝑤ℎ = −

0.75×0.457

0.025×235
= −0.058 𝑚, the absolute value of 𝑦𝑠𝑡𝑑

𝑤ℎ is larger 

than the maximum lateral displacement 𝑦𝑚𝑎𝑥
𝑤ℎ = 0.01 𝑚.  𝑦𝑤ℎ is constant when wheelset 

passing through the small radius curve, as stable curve negotiation with flange contact. 

 
Figure 35. General track with large radius curve. 

 

 

Figure 36. General track with small radius curve. 
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Figure 37. Lateral displacement of wheelset running on steady curving large radius curve 

track. 

 

 

Figure 38. Lateral displacement of wheelset running on steady curving small radius curve 

track. 

 

4.3 Manchester Benchmark 

As it showed in Figure 39, the Manchester benchmark wagon is used. The center of rear 

bogie (right side) is chosen as the zero point when measuring the vehicle travelled distance. 

To compare the results between lookup table method, KEC method and UM, curved tracks 
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are used in simulations. Kinematics comparison results are shown in Figure 40, Figure 41, 

Figure 42, Figure 43. 

 

 

Figure 39. Manchester Benchmark wagon in UM. 

 

 

Figure 40. Comparison of lateral displacements of four wheelsets traveling on R=500 m 

even track. 
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Figure 41. Comparison of yaw angles of four wheelsets traveling on R=500 m even track. 

 

 

Figure 42. Comparison of lateral displacements of four wheelsets traveling on R=500 m 

track with irregularity 



43 

 

 

 

Figure 43. Comparison of yaw angles of four wheelsets traveling on R=500 m track with 

irregularity 

 

The benchmark vehicle is simulated on 500-meter-long tracks with forward velocity 20 m/s. 

An even track is applied during the first journey. Irregularity of the track is applied during 

the second journey. The macro geometry of the track can be divided into three segments: 

100-meter-long tangent part, 50-meter-long transition part, and 350-meter-long left curve 

track part with the radius of R=500 m. The results from the lookup table method, the KEC 

method and UM agree well with each other. 

 

FF, FR, RF, RR are abbreviations of the front bogie front (wheelset), the front bogie rear 

(wheelset), the rear bogie front (wheelset), the rear bogie rear (wheelset) accordingly. The 

behavior of the lateral displacements of wheelset on the even track can be described 

separately to three sections below: 

• When the vehicle travelling on the tangent section, the hunting starts from beginning 

because of the initial 2 mm of lateral displacement. Amplitude of hunting is 

decreasing because of suspension systems. 
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• When the vehicle travelling on the transition section, the hunting end. That is because 

the track is not tangential anymore.  

• When the vehicle enters the steady curving section, the lateral displacements reach a 

constant value. It is steady because the flange contact appears, and the radius of the 

track is constant.  

 

As mentioned before, the center of rear bogie is chosen as the zero point when measuring 

the travelled distance of the vehicle. The distance between rear and front bogies is 19 m. 

Front wheelsets start changing behaviors earlier than rear wheelsets. When the vehicle 

travels on the track with irregularity, the later displacement cannot reach a steady value 

because of the influence of irregularity. 
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5 CONCLUSION 

 

 

This thesis introduced the background and advantage of railway vehicles. The railway 

transports of goods had a growing need during COVID-19 outbreak. Then it listed the 

objective of this work and introduced the structure of this thesis is introduced. The objective 

of the work is to evaluate the accuracy of the lookup table method (Escalona and Aceituno, 

2019) and knife-edge-equivalent contact constraint (KEC) method (Escalona et al., 2019) 

which are implemented in MATLAB (by Xinxin Yu) in case of Manchester Benchmark 

parameters (Iwnick, 1998). 

 

This thesis introduced theoretical foundations for the simulations: the rail wheel pairs, 

hunting, suspension systems, as well as cubic spline interpolation for profiles and 

irregularity. Then introduced integrators and the contact models of UM, GENSYS and VI-

Rail. And then showed how to use the commercial software to build a bogie with primary 

suspension. 

 

This study introduced the comparisons between the lookup table method, the KEC method 

and UM. The important contact parameters and the irregularities of the rails are emphasized 

firstly. The lookup table method, and the knife-edge-equivalent contact constraint method 

implemented in MATLAB in case of Manchester Benchmark are verified against Universal 

Mechanism. The lookup table method and the KEC method have good accuracy. The reason 

is that above two methods can get very close results with commercial software: 

• For single wheelset travelling on a tangent track, lateral displacements from the 

lookup table method and Universal Mechanism are very close. The calculated 

Klingel frequency is the same as the frequency form simulation results. 

• During the stability analysis of unsuspended wheelset on constant curvature tracks, 

the lateral displacements from the lookup table method and UM are also very close. 

The calculated result of symmetry axis on large radius curve track is the same as the 

axis measured from simulation result. 

• For Manchester Benchmark vehicle simulation, lateral displacements, and yaw 

angles of four wheelsets are measured. The vehicle is simulated firstly on a small 
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radius (R=500 m) even track, and then on the same radius track but with irregularity 

accordingly. The results from above mentioned three methods are very close.  
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Appendix 1 

Table of contact models available in GENSYS (www.gensys.se) 

p_lin  Defines a linear property 

p_lin36  Defines a linear 6x6-matrix property 

p_lin144  Defines a linear 12x12-matrix property 

p_nlin  Defines a non-linear property 

p_nlin_s  Defines an asymmetric non-linear property 

p_nlin_t  Defines a non-linear property given by tangential values 

p_nlin_st  Defines an asymmetric non-linear property given by tangential 

values 

p_kfrkc  Property designed for coupling kfrkc 

beam_1  Defines an Euler-Bernoulli beam connected to many masses 

beam_3  Defines an Euler-Bernoulli beam with variable bending stiffness 

c  Defines damper with a pre-defined property 

c_l  Damper similar to c, oriented a small angle relative to esys 

c_r  Damper similar to c, oriented a large angle relative to esys 

c_vs_d  Defines a displacement-controlled damper 

c12_b1  Defines a damping coupling between two masses of type 

m_rigid_12 

c_magic_1  Defines a rolling contact between two masses according to the 

Magic Formula 

creep_contact_1  Defines a rolling contact between two masses according to 

CONTACT 

creep_contact_6  A wheel/rail-contact that utilizes the new features in CONTACT 

v18.1.5 

creep_fasim_1  Defines a rolling contact between two masses. The normal 

contact is solved in a linear spring. The tangential contact is 

solved with Kalker's fasim routine. 

creep_fasim_2  Similar to creep_fasim_1, but the creepages are modulated 

according formulas developed by: Maksym Spiryagin , Oldrich 

Polach & Colin Cole; Vehicle System Dynamics, 13 Aug 2013. 

creep_fasim_4  Similar to creep_fasim_1, but this wheel/rail-coupling uses the 

wheel and rail profiles directly. 

creep_lookuptable_1  Defines a rolling contact between two masses 

creep_lookuptable_2  Defines a rolling contact between two masses 

creep_polach_2  Defines a rolling contact between two masses. The normal 

contact is solved in a linear spring. The tangential contact is 

solved with O.Polach's ADH-routine. 

creep_tanel_springs_

1 

Defines a rolling contact between two masses 

coupler_1  Car-car coupler, buffer and/or draw-gear 

coupler_2  Car-car coupler, buffer and/or draw-gear 

derailm_2  Defines a contact element between two bodies 

k, k_preZ  Defines stiffness with a pre-defined property 

k_l, k_l_preZ  Similar to coupl k, but rotated a small angle relative to esys 
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k_r, k_r_preZ  Similar to coupl k, but rotated a large angle relative to esys 

k12_b1  Defines a stiffness coupling between two masses of type 

m_rigid_12 

k3, k3_preZ  Defines stiffness with 3 pre-defined properties 

k3_l, k3_l_preZ  Similar to coupl k3, but rotated a small angle relative to esys 

k3_r, k3_r_preZ  Similar to coupl k3, but rotated a large angle relative to esys 

km, km_preZ  Similar to coupl k, but the user can control if the coupling shall 

generate moments on attached masses or not 

km_l, km_l_preZ  Similar to coupl km, but rotated a small angle relative to esys 

km_r, km_r_preZ  Similar to coupl km, but rotated a large angle relative to esys 

k_air3  A coupling for modeling airbags in railway vehicles. 

k_air3_exp  A coupling for modeling airbags in railway vehicles with 

exponential smooth friction in the horizontal plane. 

k_air3_mawa  A coupling for modeling airbags in railway vehicles, using 

equations for viscous flow in pipes in vertical direction. 

k_air3_mawa2  A coupling for modeling airbags as in coupling k_air3_mawa, 

but with two auxiliary air reservoirs in parallel. 

k_coil3  A coupling for modeling of vertically standing coil springs. 

kc  Defines a spring in series with a damper. 

kckc  Defines a coupling consisting of two dampers and two springs. 

The first spring and damper are connected in parallel with each 

other 

kf  Defines a friction block with series flexibility 

kf_l  Similar to coupl kf, but rotated a small angle relative to esys 

kf_r  Similar to coupl kf, but rotated a large angle relative to esys 

kf2  Defines a two-dimensional friction block with two perpendicular 

serial flexibilities 

kf2_l  Similar to coupl kf2, but rotated a small angle relative to esys 

kf2_r  Similar to coupl kf2, but rotated a large angle relative to esys 

kf3  Defines a three-dimensional friction block with three 

perpendicular serial flexibilities 

kfrkc  Defines a coupling with smooth friction and viscous damping 

kf_exp1  Defines a coupling comprising a stiffness with exponential 

friction 

kf_exp2  A stiffness coupling with a exponential shaped friction added on 

kf_exp3  A stiffness coupling with a smooth friction added on 

m_flex_1  Links a coupling to a flexible body 

m_flex_m6  Links a coupling to a flexible body with a moving attachment 

point 

cuser#  Defines a coupling whose properties are defined in an own 

supplied subroutine CUSER# (# is a number between 0 and 9) 
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